
FOXPRO Sound Programming Utility (2.1.23) 
Updated: January 12, 2020 

Page 1 of 18 

 

www.gofoxpro.com 

 

 

 

 

 

 

 

 

 

FOXPRO Programming Utility JE 

User’s Guide 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



FOXPRO Sound Programming Utility (2.1.23) 
Updated: January 12, 2020 

Page 2 of 18 

 

www.gofoxpro.com 

 

Contents 
FOXPRO Sound Programming Utility JE ........................................................................................................ 3 

Compatibility ................................................................................................................................................. 3 

Updating Java: Windows and Mac OS X ....................................................................................................... 3 

Updating Java: Linux ..................................................................................................................................... 4 

Installation on Windows Computers ............................................................................................................ 4 

Installation on Mac OS X Computers ............................................................................................................ 4 

Installation on Linux Computers ................................................................................................................... 5 

Launching the Utility ..................................................................................................................................... 5 

Source Files ................................................................................................................................................... 6 

Caller Files ..................................................................................................................................................... 8 

Bottom Status Strip ..................................................................................................................................... 10 

Category Editor ........................................................................................................................................... 10 

FOXCAST ...................................................................................................................................................... 12 

Free Sounds ................................................................................................................................................. 14 

Sound Pack Downloader ............................................................................................................................. 14 

Sound List Error Detection & Correction .................................................................................................... 16 

Bookmarks .................................................................................................................................................. 16 

Main Menu Strip ......................................................................................................................................... 17 

Troubleshooting .......................................................................................................................................... 17 

More Information ....................................................................................................................................... 18 

 

 

 

 

 

 

 

 

 



FOXPRO Sound Programming Utility (2.1.23) 
Updated: January 12, 2020 

Page 3 of 18 

 

www.gofoxpro.com 

FOXPRO Sound Programming Utility 
Thank you for using FOXPRO’s Sound Programming Utility. This software is available in a variety of formats 
and is capable of running on Windows, Mac, and Linux computer. Please take a few moments to read 
through this guide to learn how to install and use all of the various features. 

This application is provided free of charge by FOXPRO Inc. It is periodically updated without notice. You 
are encouraged to occasionally check the website to make sure you have the newest version.  

Compatibility 
FOXPRO’s Sound Programming Utility is distributed as a Windows binary (.exe), Mac application (.app), 
and Java archive (.jar). The following operating systems were tested to be compatible with this version:  

• Mac OS X (10.7.3 and newer) 
• Windows XP 
• Windows Vista 
• Windows 7 
• Windows 8 
• Windows 8.1 
• Windows 10 
• Linux (Ubuntu 12.04 LTS, Fedora 20 Desktop Edition, Cent OS 7) 

 
It’s recommended that you have the latest version of Java installed on your computer to ensure 
functionality. To determine if you have Java installed, you can visit the website shown below: 
 

 
http://www.java.com/verify 

 
 

After the webpage loads, click on the button that says “Verify Java Version.” You may be prompted with 
a security message upon clicking the button. When the page refreshes, the version of Java you have 
installed is displayed.   

Updating to the newest version of Java is very simple. This document covers the steps required for 
Windows, Mac, and Linux.  

Updating Java: Windows and Mac OS X 
Updating Java on Windows and Mac OS X requires downloading an installer. The installer performs the 
update process and does not require any additional actions from the user. To locate the update file for 
your version of Windows, go to the website below: 

 

 
http://java.com/en/download/manual.jsp 

 

http://www.java.com/verify
http://java.com/en/download/manual.jsp
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Look through the options to find the appropriate download for your version of Windows or Mac OS X. 
There are instructions on this page that provide you with adequate information on their installation 
procedure. It’s very straightforward.  

Updating Java: Linux 
Most Linux distributions have a package manager that enables users to quickly and easily install new 
software and software updates. Common types include YUM and Advanced Packaging Tool. The example 
below shows the terminal command you use to get the last version of Java installed using the Advanced 
Packaging Tool: 

 
sudo apt-get install openjdk-8-jre 
 

 
Upon completion of the installation, you can test the version of Java you have by issuing the following 
command from a terminal: 

 
java -version 
 

 

Determine which package manager your distribution features and use it to update your Java installation. 

Installation on Windows Computers 
For Windows users, you can access the official installer for the FOXPRO Sound Programming Utility JE at 
the following address (shortened URL is displayed for sizing issues):  

 
https://www.gofoxpro.com/software/public/foxpro-programming-utility-installer.exe 

 
 

After clicking on the link, run the executable file to install the utility on your computer. The installer will 
prompt you to create a desktop, quick-launch, and start menu icon to access the utility after it has been 
installed. Note: If you failed to install the latest version of Java or do not have Java on your computer, the 
application will not launch after installation completes.  

Installation on Mac OS X Computers 
Mac OS X users, you can download the compressed zip file that contains the executable JAR file along with 
the user guide. The link for the compressed zip file is located at the web address below:  

 
https://www.gofoxpro.com/software/public/foxpro-programmer-mac.zip 

 

https://www.gofoxpro.com/software/public/foxpro-programming-utility-installer.exe
https://www.gofoxpro.com/software/public/foxpro-programmer-mac.zip
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After opening the file, you will see ‘FOXPROProgrammer.jar’ and ‘userguide.pdf’. You can drag the JAR file 
into your applications folder for easy access. To launch the application, just double-click on the JAR file. 

Note: Some computers may be setup with restrictions for installation software from unknown or 
untrusted sources. You may need to adjust your security settings to all the software to be installed. 

Installation on Linux Computers 
You can also download a simple standalone deployment for FOXPRO’s Sound Programming Utility JE. The 
application is distributed in a compressed archive and downloaded from the following web address 
(shortened URL is displayed for sizing issues): 

 
https://www.gofoxpro.com/software/public/foxpro-programmer.zip 

 
 

After you download the file, open it up to view the contents. You will find the following: 

• FOXPROProgrammer.jar 
 
The first file ‘FOXPROProgrammer.jar’ is the utility. The file is an executable standalone Java file. You must 
store this file in an easy to access location on your computer. Some folks may choose to create a directory 
called ‘FOXPRO’ and then store the file there for future access.  

Linux users need to set the executable bit on the JAR file before launching it. If you create a folder called 
‘FOXPRO’ in your home directory and store the jar file there, open a terminal and do the following: 

 
cd FOXPRO 
chmod +x FOXPRO-Programmer.jar 
 

Launching the Utility 
Prior to launching the utility, it is recommended that you have your FOXPRO game call connected to your 
computer. Each FOXPRO game call ships with an instruction manual that contains adequate details on 
how to connect your device to a computer. Follow those instructions.  

On Windows and Mac OS X, launching the utility is as simple as double-clicking on the file ‘FOXPRO-
Programmer.jar.’ On Ubuntu Linux, you can launch the utility by right-clicking on the icon and then 
selecting ‘Open with Java Run Time.’ Some Linux systems may require that you launch the application 
from the command line by using ‘java –jar /path/to/FOXPROProgrammer.jar’. 

Upon launching the utility, you will be presented with a screen similar to the following: 

https://www.gofoxpro.com/software/public/foxpro-programmer.zip
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The above image is the main interface. The interface is divided into two main sections: Source Files (light 
green) and Caller Files (light orange). Source Sound Files represents your collection of sounds or personal 
sound library stored locally on your computer. The Caller Files section represents the contents of your 
FOXPRO game call. The bottom section (light yellow) shows information about the FOXPRO device that is 
connected to the computer. 

The interface has a variety of buttons that allow you interact with your FOXPRO game call. All operations 
of the utility are discussed in the following sections. 

Source Files 
The Source Files side (image on next page) features several buttons and a list box. Source Files represents 
sound files that are stored on your computer only.  

By default, the application looks for new sound files in a specific location on your hard drive. On Windows 
and Mac OS, the typical local is under ‘Documents->FOXPRO->Sounds’ and on Linux it checks a folder in 
‘~/FOXPRO/Sounds’. If valid sound files are found in these locations, they will be listed in the Source Files 
column.  
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Current Source Files Path shows the path to the directory that the application is looking for new sound 
files in. If new files are present and compatible with the connected FOXPRO device, those files will appear 
in the Source Files column. You can change the current source path by clicking on the Browse button and 
navigating to a different location on your computer. Note: The source and caller cannot be the same. 

Directly beneath the Source Files column you will find three buttons: Info, Refresh, and Select All. The 
Info button displays information about the currently selected sound file. For example, if you have “120 
Crazy Critter.fxp” selected, the Info button will provide you with the name, file type, duration, and file 
size. This button can report back information on most FXP, 24B, MP3, and WAV audio file types. 

The Refresh button refreshes Source Files if that directory has changed outside the scope of the 
application. Select All simply selects all of the sounds in Source Files.  

To the right of this section is the Insert button. This button will insert the selected sounds from the Source 
Files into Caller Files.  

Inserting new sounds into Caller Files happens in real time. When you insert sound from Source Files into 
Caller Files, the insertion process is instant. There’s a couple of ways that you can load new sounds from 
Source Files into the Caller Files column.  

Using the Insert Button 
1. Highlight one, multiple, or all of the sounds listed in the Source Files column.  
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2. Click on the position in Caller Files that you would like to begin insertion. If a sound already exists 
at the point of insertion, that sound and all subsequent sounds will be pushed up the list to make 
room. Note: if you do not click on a spot in Caller Files, insertion automatically begins at the first 
empty spot in the list. 

3. Click on the Insert button in the middle of the screen. A status bar will appear keeping you up to 
date on the progress of the insertion. When complete, the status bar closes and the screen returns 
to normal. The Caller Files column then displays the new additions. 

Using Drag and Drop 
1. Highlight one, multiple, or all of the sounds listed in the Source Files column. 
2. Click on the position in Caller Files that you would like to begin insertion. If a sound already exists 

at the point of insertion, that sound and all subsequent sounds will be pushed up the list to make 
room. Note: if you do not click on a spot in Caller Files, insertion automatically begins at the first 
empty spot in the list. 

3. Click and drag the highlighted sound(s) from Source Files into Caller Files. A status bar will appear 
keeping you up to date on the progress of the insertion. When complete, the status bar closes 
and the screen returns to normal. The Caller Files column then displays the new additions. 

The Source Files column can have files dropped directly onto it. If you download a FOXPRO sound pack, 
you can drag and drop the compressed (.zip) sound pack file on the column to import the new sounds 
right away. You can also drop FXP, 24B, MP3, and WAV files for immediate import into your local sound 
library.  

Caller Files 
The Caller Files column (image to the 
right) is populated with the list of sound 
files stored in the FOXPRO device that is 
connected to the computer. Notice the 
green box in the upper-right corner of the 
image. The green box indicates that a 
valid FOXPRO device is now connected. If 
a valid device is not connected or not 
found, this box will be red. If an operation 
is ongoing (inserting files) the box will be 
yellow. 

To the right of the Caller Files column 
there are five buttons: Move Up, Move 
Down, Rename, Remove, and Info. Each 
of these buttons interacts with sound(s) 
selected in the Caller Files column. For 
example, if you highlight sound 009 and 
then push Move Up, sound 009 will switch 
places with sound 008. Using Move Down 
while you have 009 highlighted results in 
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009 and 010 switching places. You can select multiple sound files and move them together as a group. 
The Remove button results in the highlighted sound(s) being deleted from the FOXPRO device. Rename 
enables you to rename the selected sound. Be aware, renaming the sound does not affect the sound 
position value. The Info button displays information about the currently selected sound file. For example, 
if you have “000 Coyote Locator.fxp” selected, the Info button will provide you with the name, file type, 
duration, and file size. This button can report back information on most FXP, 24B, MP3, and WAV audio 
file types. 

Beneath the Caller Files column you’ll find 5 more buttons: Erase List, Backup Sounds, Set Channel, Edit 
Categories, FOXCAST, and Print List. Two of these buttons (Edit Categories and FOXCAST) will only be 
available on certain FOXPRO devices. Erase List allows you to quickly remove all files from the FOXPRO 
device. Be sure to make a fresh backup prior to erasing your entire list!  

The Backup Sounds button allows you to perform a backup. Backing-up your FOXPRO device means that 
you are making a localized copy of all valid sound files within the FOXPRO device to a specific location on 
your hard drive. When you click on Backup, you will see a screen similar to the following: 

 

The Browse button allows you to change the default backup location. The Perform Backup button starts 
the actual backup process. Append todays date to backup path provides a way of archiving your backups 
dynamically. When you click mark this checkbox, a new folder is created in your default Backup location 
featuring the current timestamp. For example, with a CS24C connected, the result of Append Date is a 
new folder titled: ‘CSC_20140515_100500’. The cancel button closes the Backup window. When an active 
backup process is happening, the status overlay appears showing the progress. 

The Set Channel is only active on the models XWAVE and X2S. By clicking this button, you are able to 
change the radio channel within a valid range of 0 – 15. After changing the radio channel via the utility, 
you must also change the radio channel on your TX1000 remote control so that the two devices are able 
to communicate.  

The Print List button allows you to print a list of all files inside of the connected FOXPRO game call. If the 
connected device is an FX3 or SC3, Print List will produce appropriate sized labels that you can affix to the 
back of your TX5LR remote controls along with a secondary list that can be attached to back of the FX3 or 
inside the lid of the SC3. Any other model, Print List will produce a single list of all files. If your device has 
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a large number of sound files, the list itself contains up 400 sounds per page and multiple pages may be 
produced.  

Finally, you will notice the Append Position Number. When inserting new sounds into the game call, there 
may be times when you want to preserve a particular file name. For example, if you have a FOXPRO file 
named “207 Coyote Locator” and insert it into the game call, the “207” will be changed to the position 
value for where the sound is being inserted. If you are inserting a non-FOXPRO sound, the first 4 characters 
of the file name will be automatically overwritten with the position value indicator. For example, if you 
have a sound titled “My_Custom_Sound.” When you insert it, it will change to “000 ustom_Sound.” To 
preserve the entire file name, make sure that you click the Append Position Number to file name 
checkbox.  

IMPORTANT NOTE: All operations pertaining to move, remove, erase, and insert and occur in real time. 
This means that if you choose to delete a file from the connected FOXPRO device, it is removed 
immediately. Be sure that you perform a backup PRIOR to making any drastic changes to your FOXPRO 
device. Failure to make a backup can result in loss of sound files! 

Bottom Status Strip 
Across the bottom of the interface is the status strip (see image below). This strip displays the device type, 
sound usage and capacity, and free space. If no device is connected, each of these box displays “Scanning 
for device…” until a valid FOXPRO device is connected. 

 

Category Editor 
On FOXPRO game calls that feature the TX1000 remote control, Category Editor provides you with a 
method of managing your category file through an interface rather than manually modifying the 
categories file. When you click on Edit Categories button, you will see a screen similar to the following: 
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The screen is split into two main sections: Sounds on Device and Category Assignments. Sounds on Device 
provides a list of all sound files that are installed in your FOXPRO game call. The Category Assignments 
column displays all categories in a tree view. Each category name has a symbol to the left of it, click on 
this arrow to view the individual sounds in the category. The image below shows the contents of the 
Coyote category: 

 

The New Category button allows you to create a new category. It will prompt you for a name for the 
category. After you enter the name, the new category will appear in the category tree. An empty category 
does not appear with a folder icon. The icon will not turn into a folder until you have added content to it. 
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The Insert button allows you to add sounds from the Sounds on Device column into a specific category. 
You must click on one or more sounds on the left to highlight them. Then click in a category to insert the 
selected sounds there. You can pick specific spots within the category in which to insert the sound(s). 

The Remove Selected button allows you to remove individual sounds or entire categories. Highlight a 
sound within a category or an entire category then push the Remove to delete them. This has no impact 
on the Sounds on Device column. 

The Rename button allows you to rename a category.  

The Up and Down buttons enable you to move the sound selected in the Category up or down within the 
specific category. You can also use this to move entire categories up or down the list. This has no impact 
on the Sounds on Device column.  

Save & Exit will update the category file in your FOXPRO device or simply click on the close box on the 
upper-right of the screen to exit without saving. 

FOXCAST 
On FOXPRO models that support FOXCAST, you can use this button to launch the FOXCAST sequence 
editor. This editor allows you to create new sequences or modify existing sequences. After clicking on the 
button, you will a screen similar to the following: 

 

The screen is split into three main sections: Sounds in Caller, Commands, and Sequence If your FOXPRO 
product supports FOXCAST, it is recommended that you read the section of your product manual 
pertaining to FOXCAST to understand the basic concepts behind how it works prior to working with the 
editor. The editor will make much more sense if you have a general foundation for understanding how 
FOXCAST works.  
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The Volume button allows you to add a volume command (V) to the sequence layout. Valid volume levels 
typically range 0 – 40. You will be prompted for a volume level when you click on the button. If a non-valid 
value is entered, it will inform you that it is not valid.  

The Sound button enables you to add a new sound entry to the sequence layout. You must first browse 
through the Sounds on Caller, click on the sound you wish to add, then click on Sound. You will be asked 
how many times you would like to have the sound repeat.  

The Pause button allows you to add a pause to the sequence layout. Acceptable pause values range from 
1 – 99999 seconds.   

On some FOXPRO models, you will find the Decoy button active. This allows you to add in the decoy on 
or off command to your sequence layout. When you click on this button, it will prompt you to specify 
whether you wish to issue a decoy on or off command. 

On some FOXPRO models, you can turn on FOXMOTION to a specific setting by using the FOXMOTION 
button. When you click on the button, it will prompt you to add the appropriate value (0 – 4).  

On some FOXPRO models, you can activate FOXPITCH through the FOXPITCH button. When you click on 
FOXPITCH, it will prompt you for the appropriate value to assign to FOXPITCH from the range 0-19. 

The sequence layout box is completely editable. You are welcome to click into the box to add, delete, 
rearrange, or custom modify the sequence as you wish. Just be sure that you fully comprehend how the 
sequences must be designed.  

The Open button allows you to browse your FOXPRO game call or hard drive for existing sequence files 
and then open them for view/edit.  

The Save button allows you to save the sequence layout as an actual sequence file. When saving a 
sequence, you must conform to the standards of, for example, ‘S00 My Sequence.seq’, however, if you 
forget to add the ‘.seq’ to the file name, the editor checks for it and will add it for you.  

The Clear button allows you to clear the sequence box. 

IMPORTANT NOTE: When you are adding commands to the sequence layout, make sure that you 
highlight the spot in the layout that you want that command to appear. As you insert new commands 
into your sequence, the highlight bar should automatically add a blank line or advance to the next line, 
but you should always double-check that you have a position selected that you want the command to 
appear. 
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Free Sounds Downloader 
The image to the right shows the window that appears 
after you click on File -> Download Free Sounds (or 
Control + F from the main interface). 

In order to download free sounds, you must be connected 
to the internet. When you click on Download Free 
Sounds, the application retrieves a list of all free sounds 
available from the FOXPRO website. You can then click on 
specific free sounds or select them all (magic wand). By 
clicking on the Download Selected button, you are able 
to download the selected free sounds to your hard drive. 

Depending upon your internet connection, it may take a 
few minutes for the sounds to download. The operation 
status overlay will appear keeping you up to date on the 
progress. When completed, the free sounds will appear in 
the Source Sound Files column on the main window.  

Note: You will have to accept a license agreement before 
you can download the free sounds. 

 

Sound Pack Downloader 
This is feature was introduced to the FOXPRO Programming Utility JE in the 2.1.5 version. This exciting 
new feature allows you to link the software to your online store account for the purposes of 
downloading sound packs that you have purchased. Keep in mind: this is intended to download sound 
packs that you have purchased, not the purchasing of new sound packs.  

To login to your account, click on the File menu and then click on Sound Pack Downloader. A new 
window will appear as shown in the screenshot below.  
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The first thing you must do is sign-in to your store account. Enter the email address you used when 
signing up for the account and your password, then click the Login button. If you the account credentials 
are correct, the small field on the bottom-left of the interface will display “+User Authenticated”. Also, 
upon successfully accessing your account, the box on the right side of the display will populate with the 
list of all sound packs you have purchased to date. The sound packs are listed by their FPDLC ID number 
associated with the online store. You can highlight one of the list sound packs by clicking on it. From 
there, you can click on View Sounds to see all of the sounds featured within the sound pack. You can 
also click the Download Selected button to download the sound pack from your store account to your 
computer. Please note that when you download a sound pack, the sound pack is automatically parsed 
and the sounds from the sound pack will be imported in to your Source Files column and will be 
available for immediate insert into your game call. Having this integrated into the programming utility 
will help simplify the process of downloading and install new sounds into your FOXPRO game call. The 
actual compressed sound pack file will be saved to your Documents -> FOXPRO folder. The file name will 
be something to effect of “FPDLCXXXXX.zip”.  

What is the FPDLC ID? Each time you purchase a sound pack through the online store, the sound pack is 
assigned a unique “FPDLCID” which stands for FOXPRO Downloadable Content Identification. If you login 
to online store through the website, click on the My Account menu and then click on Sound Pack 
Download Manager, you will see all of your available sound packs. Each one of the listed sound packs 
has an FPDLC ID next to it. You can use this to reference sound packs through the Sound Pack 
Downloader in the programming utility, if needed.  

If you are trying to sign in to your account, but you forget the account password, be aware that you can 
only try logging in 10 times unsuccessfully until the account is becomes locked. When the account is 
locked, you will not be able to try signing in for a period of time. You can access the FOXPRO website 
and use the password reset if needed.  

When you are finished using the Sound Pack Downloader, simply push the close button on the upper-
right corner of the Sound Pack Downloader window and you will return back to main interface.  
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Sound List Error Detection & Correction 
When you launch the programming utility, it performs an initial scan of the sound list in your game call. 
If it detects a problem within the sound list, it will alert you with following prompt: 

 

If you encounter this prompt, it is highly recommended that you allow the utility to run the auto-
correction procedure. This procedure sweeps the sound list and automatically makes adjustments to 
resolve problems. For example, if you have a Spitfire memory card connected to your computer and it has 
48 files on instead of 24, it will move the excess sounds into a folder in the memory card called 
“AutoFix_Moved_files” so that you can retrieve them later. After the auto-fix procedure has completed, 
a status update box will appear that provides you with a review of what it has done. 

Bookmarks 
Bookmarks are shortcuts to locations on your computer 
where sounds are stored. This is especially useful if your 
personal sound library is segmented by species or 
spread out across many different folders.  

Let’s say you have a large quantity of sounds stored in a 
single folder. Scrolling through the entire list to find a 
specific sound can be time consuming. Instead of 
keeping all sounds in a single folder, dividing them into 
their own unique sub-folders per species provides new 
level of organization. You can then create bookmarks for 
each sub-folder to access those specific sounds quickly. 
If you want to view only coyote sounds, click on Edit -> 
Manage Bookmarks (or keyboard shortcut control + b), 
click on the bookmark for the coyote folder, and the click 
Load. The Source Files column instantly populates with 
the sounds stored in that folder. 

Creating New Bookmarks 
1. Access the bookmark editor from the Edit Menu -> Manage Bookmarks. 
2. Click the New button. 
3. A file browsing dialog box will appear. Use this dialog box to navigate to the location on your hard 

drive where you have specific sounds stored. When you get to that folder, the sounds stored in 
that location should be visible in the box.  
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4. You can double-click on one of the sound files in the folder to set the current path as a new 
bookmark.  

5. The bookmarks list will display the new location at the bottom. 

Loading a Bookmark 
1. Access the bookmark editor from the Edit Menu -> Manage Bookmarks. 
2. Click on the bookmark you wish to load from the list. 
3. Click the Load button. 
4. The Bookmark Editor screen will close and the Source Files column will populate with the sounds 

stored in that location. 

Editing a Bookmark 
1. Access the bookmark editor from the Edit Menu -> Manage Bookmarks. 
2. Click on the bookmark you wish to edit. 
3. Click on the Edit button. 
4. A file browsing dialog box will appear. Use this dialog to navigate to the new location on your hard 

drive where you have specific sounds stored. When you get to that folder, the sounds stored in 
that folder should be visible in the box. 

5. Double-click on one of the sound files to set the current path as the bookmark. 

Deleting a Bookmark 
1. Access the bookmark editor from the Edit Menu -> Manage Bookmarks. 
2. Click on the bookmark that you wish to edit. 
3. Click on the Delete button. 

Main Menu Strip 
The main menu strip across the top of the interface has three options: File, Edit, and Help. By clicking on 
the File menu you will reveal Import FOXPRO Sound Pack, Download Free Sounds, Sound Pack 
Downloader, and Exit. The Import FOXPRO Sound Pack item will enable you to import a FOXPRO sound 
pack file directly into the Source Files column. Download Free Sounds was covered earlier in this guide.  

The Edit menu gives you access to Mange Bookmarks.  

The Help menu contains a number of options. Online Manual attempts to launch your computers 
default web browser to connect you to the online guide for reprogramming your game call. System 
Messages opens a window that displays any error messages or other messages that may have been 
thrown by the utility during its operation. If you call FOXPRO for technical support, they may have you 
open this to check for different error states. System Overview provides information about your local 
system—this can be useful for technical support calls. About this Program displays information 
regarding the version, build date, and provides a mechanism for checking for updates. 

Troubleshooting 
If you experience any trouble with the application, here are a few pointers that may help you out.  

• Make sure that you have the latest version of Java installed on your computer. Mac OS X does 
not come with Java installed by default—therefore, you may have to install it manually. This can 
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be completed easily by visiting the official Java website at: http://www.java.com Installations 
for all major operating systems are available.  

• If you open the utility, then connect a valid FOXPRO device, and the utility fails to recognize the 
device, try closing the utility, reconnecting the device to the computer, and then reopening the 
utility. During the startup process of the utility, it should recognize the device.  

• ALWAYS properly eject/safely remove your FOXPRO device from the computer prior to 
unplugging it! Many problems can be avoided by making sure that you follow this 
recommendation—especially on Mac OS X.  

• Check the error log for information pertaining to an encountered error state. You can view the 
error log by pushing the F2 button on your keyboard, or by clicking on the Help menu and then 
selecting System Messages. You can also access the raw log file by navigating to Documents -> 
FOXPRO -> jeconfig folder and then opening the file “fppu.log” in a text editor such as Notepad. 
This file contains any error messages thrown during operation. This may also be useful for a 
support agent helping you over the phone.  

• If you are trying to reprogram a memory card for a unit (ex: Spitfire, Wildfire, Scorpion X1B, 
Scorpion X1C)  and you are unable to add sounds to the card, check that you are using a micro 
SD card reader/writer and not just a reader. In addition, if your card adapter has a small slide 
switch, make sure that it is in the “unlocked” position—typically indicated by a picture of a lock. 
If the card adapter is locked or just a card reader, then you will be unable to make any changes 
to the memory card until it is unlocked or a proper reader/writer is obtained.  

• If you receive an error message regarding errors in the playlist when the application first loads, 
it is recommended to allow the application to fix the problem. If you ignore the problem at this 
stage, the problem will still be present later and will cause you additional grief. Most errors are 
caused by having incorrectly named files present inside of the device. This can be in the form of 
duplicates, missing or skipped numbers, and files that are number in proper sequence with the 
rest. The Auto Fix feature is designed to help take care of the errors quickly and easily.  

More Information 
FOXPRO’s official website has a lot of useful resources to help you get the most of your FOXPRO game 
call. You can find instructional content on programming, articles on hunting, product videos, and the 
Furtaker’s webisodes. Be sure to stop by regularly to stay up to date on the latest information from 
FOXPRO! 

http://www.java.com/
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